Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Create an account

    Want more? Register now and get full access to our community!

Don

Download — SavrenX Schlong of SAM Light + HDT PATCH ( SKYRIM SE ONLY )

Recommended Posts

For those hitting the camera falling to waist (or lower) problem, are you running any additional SOS addons alongside the default ones included with this mod (e.g. SOS Pubic hair for females)?

Share this post


Link to post
Share on other sites

Hey Guys,

I am quite new on Skyrim modding, actually I am using Skyrim SE with MO2 as the tool to manage my mods. After a quick check I have SAM Light working well on my game, but I have some issues>

  1. In RaceMenu, If I try to change diffuese or other texture attribute I end up with a purple glowing body. Somebody said hat I need to add textures so I addes SAM light Textures Addon, but nothing changes.
  2. Sometimes the game crashes due to x or y cause, and the schlong is working but the underwear remains.
  3. The face, Actually I feel quite jealous because some of you shared amazing captures of your characters with good faces, but I have an amazing body, but the horrible face quite close to standard. I have downloaded several faces add-ons but I don-t know how to make it work in the game.

Do you have any reference on how to install textures, faces or how to change it in the RaceMenu?.

Thanks all..

Btw.... SAM Light is the best body mod I've ever tried!....

Share this post


Link to post
Share on other sites
7 minutes ago, artoffugue said:

Did you download SAM Morphs for RaceMenu and follow this guide? 

Texture Selection (SAM Light only, textures not included)

  • Swap to different diffuse, normal, and specular maps for the body, hands, and feet*
  • Requires refits with body parts correctly named for SAM (SAMBody, SAMHands, SAMFeet, SAMGenitals, SAMForeskin)
  • Textures follow the naming convention BaseName_xx.dds (diffuse), BaseName_xx_msn.dds (normal), BaseName_xx_s.dds (specular) where xx ranges from 01 to 10
    • For example, base texture malebody_1.dds would be named malebody_01.dds, malebody_02.dds, malebody_03.dds, etc.
  • Feet textures have the BaseName of MaleFeet (default races), ArgonianMaleFeet (Argonian), and FeetMale (Khajiit)

*feet uses body texture by default

Great and Thanks for your response.

I just have a question. Where is the texture folder located?, inside Sam Light or inside Morphs for Racemenu.

 

Share this post


Link to post
Share on other sites
1 minute ago, artoffugue said:

SAM light or SAM light texture addon, i assume.

Ok, I am more clear right now.

Sorry to abuse, but... I understand that each texture available could come with the face texture included, but do you know if there are other good faces sources?

Share this post


Link to post
Share on other sites
On 7/16/2020 at 10:18 AM, Grumm said:

For those hitting the camera falling to waist (or lower) problem, are you running any additional SOS addons alongside the default ones included with this mod (e.g. SOS Pubic hair for females)?

I originally used this with Futa SOS. but when I tested it on pure skyrim and even with a different female torso, the same problem occurred. the problem manifested itself when equipping wigs or clothing, most often hdt, and only for female characters. sorry my English is not very good and I use a translator with some text corrections.

Share this post


Link to post
Share on other sites

To anyone still having problems with the .dll error message or perma-undies this specific SOS port's .dill file helped. Open the SOS archive and navigate to .dll and copy it. Next open this mod and navigate to its .dll. Delete it and pasted the .dll from the SOS file. Finally Install this mod through the use of your chosen mod manager.

Incase mod doesn't load here's the original mod page: https://www.loverslab.com/files/file/5355-schlongs-of-skyrim-se/

Schlongs_of_Skyrim_SE - v1.1.4.rar

Share this post


Link to post
Share on other sites

This mod's broken for me for some reason. I tried using it on the most minimal mod load order with SkyUI, UIExtensions, Racemenu, SAM Morphs for RaceMenu, Alternate Start Live Another Life, Sam Light, Schlong of Sam, Sam High Poly Conversion SE, and XP32 Maximum Skeleton, in that order. I tried switching Schlong of Sam and Sam High Poly and what happens is that if Schlong is put first, if I put a texture on the body, it applies only on the crotch area, and if Schlong of Sam is put after, both of the genital meshes stay or if I use the nevernude version of the high poly conversion, the underwear never comes off.  If anybody could help me, tysm in advance. 

ScreenShot11.pngScreenShot10.pngScreenShot9.png

Share this post


Link to post
Share on other sites

I have use this mod and I had never had issues.......

 

Here's my load order:

SkyUI

UI Extensions

Racemenu

Sam Light

Sam High Poly

SavrenX Schlong of SAM Light

SavrenX Schlong of SAM HDT patch (if you are using physics)

SAM Light Texture Add-on

BodySlide and Outfit Studio

SAM Morphs for Racemenu

HDT-SMP (if you are using physics)

HDT-BBB for SAM (if you are using physics)

FNIS SE

XPMSE

 

 

ScreenShot7.png

ScreenShot8.png

 

 

Edited by Dee Aeriel

Share this post


Link to post
Share on other sites
4 hours ago, Dee Aeriel said:

I have use this mod and I had never had issues.......

 

Here's my load order:

SkyUI

UI Extensions

Racemenu

Sam Light

Sam High Poly

SavrenX Schlong of SAM Light

SavrenX Schlong of SAM HDT patch (if you are using physics)

SAM Light Texture Add-on

BodySlide and Outfit Studio

SAM Morphs for Racemenu

HDT-SMP (if you are using physics)

HDT-BBB for SAM (if you are using physics)

FNIS SE

XPMSE

 

 

ScreenShot7.png

ScreenShot8.png

 

 

I tried following the steps above, and I ended up okay but when I put texture on the body there seems to be two dick meshes :/

ScreenShot4.png

Share this post


Link to post
Share on other sites

Hey, wondering if I could get some help. Everything works fine except for the fact that the schlong texture won't load, it's like it's missing. Works fine without the custom textures. Can post load order if needed

The Elder Scrolls V  Skyrim Special Edition Screenshot 2020.11.27 - 17.24.55.27.png

Share this post


Link to post
Share on other sites

I was trying out the mod and saw that the argonians have a low poly texture for the schlong. I am using both High Poly SAM and Masculine Argonians and I really can't find the source of the problem

Share this post


Link to post
Share on other sites

Low poly mesh or low definition textures?

If the problem is the mesh you could try taking the schlong mesh from High Poly Body, remove the body, change the slot to 52 and replace the mesh. I did this recently when switching from another body to SAM, but I've had several issues with textures not beding correctly around the mesh and creating an awful mess. Sometimes textures are tailored to a specific mesh and switching either just doesn't work. In that case, if Polys are more important than textures, you could consider switching to SAM Light Texture addon (I don't play Argonians so I don't know how different the two texture sets are), and changing the genital texture path in the Creation Kit to the regular body textures. EDIT: I had a doubt so I downloaded the Addon again and it doesn't look like that mod has body textures for the beast races. On the other hand, I distinctly remember having beast textures with the Schlong integrated on the same .dds as the rest of the body, since I went through the process I've described recently. They probably come with one or another SAM mod on this site, I just don't remember which, sorry. 

If the problem is the texture you need to restore the textures of the other mod if they have been overwritten, and then check inside the CK if the Texture Addon points to the correct path. I see this mod doesn't have schlong textures while the other mod uses the SAM Full (which only works on LE) approach to textures, which gives the schlong textures a different path from the textures used by SOS and so would be ignored by this mod's SOS addons. You either need to select the texture set you use, rename them and drop them in the correct folder replacing the SOS textures, or change te texture path in the CK.

These are the steps I'd try or have tried since I've also had problems matching Schlong meshes and textures when I switched to SAM Light, but I'm neither an expert in modding nor familiar with the inner workings of SAM, so if they don't work or someone else with more experience is able to direct you better disregard this and listen to them.

Edited by ElderVerK

Share this post


Link to post
Share on other sites

Hey all, I have an issue when using SAM Light and the Racemenu Morphs alongside SOS (So the SAM bodies and schlongs are being used) where if I apply a texture overlay to the schlong, the normal mapping seems to go wack on the schlong, I can't quite figure out how to either: A. Change the schlong normal/diffuse independent to the body, or B. Make it so changing the body diffuse/normal doesn't effect the schlong at all.

Oh and NPC's appear to have it even worse, their schlongs appear as if they're using the diffuse of the body as well, I understand that's how SAM light works by default, with the body and schlong being one mesh, but obviously I've changed that so it works properly, and the schlongs are being loaded through SOS with the body meshes having no schlongs attached, but I guess something is going wrong somewhere down the line, I'm not sure how to fix it though.

Any help would be super appreciated.

Edited by gaymoleman69

Share this post


Link to post
Share on other sites
1 hour ago, gaymoleman69 said:

Hey all, I have an issue when using SAM Light and the Racemenu Morphs alongside SOS (So the SAM bodies and schlongs are being used) where if I apply a texture overlay to the schlong, the normal mapping seems to go wack on the schlong, I can't quite figure out how to either: A. Change the schlong normal/diffuse independent to the body, or B. Make it so changing the body diffuse/normal doesn't effect the schlong at all.

Oh and NPC's appear to have it even worse, their schlongs appear as if they're using the diffuse of the body as well, I understand that's how SAM light works by default, with the body and schlong being one mesh, but obviously I've changed that so it works properly, and the schlongs are being loaded through SOS with the body meshes having no schlongs attached, but I guess something is going wrong somewhere down the line, I'm not sure how to fix it though.

Any help would be super appreciated.

You weren't very descriptive of the steps you've taken "so that it works properly" so I'll probably say the obvious, but have you also changed the texture paths in the Creation Kit?

As far as I understand the issue, you've taken the SAM Light Schlong and used it to replace the SOS one, but SOS has texture paths for each race written in the Creation kit which override the texture path you find in the .nif. Since the UV map between the SAM and SOS schlongs changes quite a bit, you need to change the texture sets in the creation kit to match the set of textures that goes with the shape. That might make swapping textures through SAM morphs incompatible depending on whether or not SOS ovverrides the texture change with it's own paths.

Share this post


Link to post
Share on other sites

Sorry, my bad, so I originally set this up for LE, and only brought forward things I couldn't find properly ported to SE, so I used a NIF optimizer to optimize the SAM schlong, and I think that's the only mesh asset I brought over.

Now to answer your question, no I haven't changed the texture dirs in the CK, I instead just replaced the default SOS schlong textures with SAM ones, also upon looking at the NPC's again in game actually it appears I was wrong, the NPC's do have the correct schlong textures but they appear as if they have no normal map applied to them at all, they look like they have a flat normal almost. The problem mainly just seems to be with the normal maps either completely failing to apply to an NPC, or applying the entire body normal map across the schlong.
 

Spoiler


GkYMbz8.png

 

I rooted around in the Racemenu SAM morphs addon in the CK and SSE Edit but I couldn't really see anything that'd make the selected normal map not apply to the schlongs armor slot or anything.

Maybe I should try using the LE version of the Racemenu SAM Morphs? I have no idea how much Racemenu has changed between LE and SE. Nope, no luck there either...

Edited by gaymoleman69

Share this post


Link to post
Share on other sites

Yeah, if the textures path isn't the issue then it's definitely the mesh's problem. The mesh from this mod have SOS UV maps, which aren't compatible with SAM Textures. The UV map is basically a projection of all the vertices that make up the 3d mesh on the 2d texture file, so that each triangle takes up a piece of the cake. Applying the whole body textures across the schlong can happen when the UV map of the mesh extends across the whole dds which is what the SOS meshes have as UV map.

1439948662_WandIssues.thumb.png.c0d80f16a46e03f44ee3b428e97dbf82.png

(The upper half is what I understand is your situation. I made the texture path go to malebody.dds to replicate your situation because I don't have SOS texture folders anymore and in the end that's the texture that's being applied to the shape, regardless of folder structure) 

To make it look like the lower half I'd suggest downloading SAM (normal or high poly) again, loading the body in Outfit studio or nifskope, delete the SAMbody shape (it's separate from the SAMgenitals shapes so it's very easy to do) and change the schlong's partition from 32 to 52, which is what I did to fix the issue. After that you can either replace the SOS textures, or especially if you use heavy 4k body textures you can save some disk space by opening the Schlong's esp in the CK and alter a few lines under "Texture set".

Edited by ElderVerK

Share this post


Link to post
Share on other sites

Hmm, I get what you're saying, but if I edit/move the UV then the diffuse will be out of place, and so will the normal when a schlong isn't having a different normal applied to it through racemenu. SOS is loading the schlong diffuse and normals usually, but for whatever reason it's not loading the normals for the NPC's (That might be a CK issue which I'll check) however it does load the schlong normal on the player characters schlong, but once I apply a racemenu overlay, it applies to the schlong as well, which is problematic because ideally I'd want to load a separate alternate normal on the schlong, or none at all, there is the racial power to separate the feet and body diffuses/normals, but there doesn't appear to be a way to separate the schlong and the body.

I'm not sure I fully understand what you're saying at the end of your post though, are you saying that, in your game you have your schlong diffuse/normals baked into the body textures, like in SAM light? Even though you're still using SOS's framework. I suppose I could do that too, but I don't use any particularly HD textures or anything, so it'd be a shame to lose so much graphical fidelity on the schlong squishing it in there between the foot and the ass textures.

 

Edited by gaymoleman69

Share this post


Link to post
Share on other sites

I can't, for the life of me, figure this out. It sounds simple enough - just replace the SchlongsOfSkyrim.dll file in Sam Light folder with the the file from the Schlongs of Skyrim folder - yet that doesn't seem to work. It still tells me the dll is out of date and there's still undies on my character and no schlongs loaded in the SOS MCM. My SKSE is a version higher than listed for the SOS mod, but that shouldn't matter because SOS was working just fine with it before I decided to start fresh so that I could try out the SAM body.

If I can't get this mod to work... do I need this? Is this the only way to get SOS and SAM to work together? (So many mods on LL are dependent on SOS.)😞

Share this post


Link to post
Share on other sites
6 hours ago, Safyre said:

I can't, for the life of me, figure this out. It sounds simple enough - just replace the SchlongsOfSkyrim.dll file in Sam Light folder with the the file from the Schlongs of Skyrim folder - yet that doesn't seem to work. It still tells me the dll is out of date and there's still undies on my character and no schlongs loaded in the SOS MCM. My SKSE is a version higher than listed for the SOS mod, but that shouldn't matter because SOS was working just fine with it before I decided to start fresh so that I could try out the SAM body.

If I can't get this mod to work... do I need this? Is this the only way to get SOS and SAM to work together? (So many mods on LL are dependent on SOS.)😞

You might want to try the update version in the download section. It should be way easier to install and all up to date with High Poly and physics.

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, ElderVerK said:

You might want to try the update version in the download section. It should be way easier to install and all up to date with High Poly and physics.

Ah! I don't know how I missed that. 😵I've been going crazy. Thanks! I'll give that a try instead.

Edit: Yay! It works! Now I can move on to working on character design and figuring what other mods I want to play with. Thank you! 😄

Edited by Safyre
Update without making new post.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.