Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Create an account

    Want more? Register now and get full access to our community!

KouLeifoh

Download — High Poly Head

Recommended Posts

I am MOST annoyed at this problem. It's driving me crazy. Everytime I choose the High Poly Head, my character's eyebrows totally dissapear and hair partially dissappear to show a very ugly view when in close up. WHY???

Here's what happens in a screenshot.

spacer.png

The ONLY fix I found was to dissable the fading with this mod: https://www.nexusmods.com/skyrimspecialedition/mods/19310

Share this post


Link to post
Share on other sites

"High Poly Head.esm not found in load order" appears whenever I used your script to apply the high poly versions to every vanilla NPC. It's definitely loaded since I only check your mod's ESM and the DLC ESMs. I apply the script on the DLC ESMs and it spits out that error.

Share this post


Link to post
Share on other sites

I want to use this mod, but CK doesn't reflect the correct features.

The face in CK:
image.thumb.png.5634e4df9e9df52a7ea97c56d8490b4b.png

The face in Nifskope:
image.thumb.png.1f9634f2416fcaa2c58184d4c40f9986.png

So I'm unable to get to the point where I can swap the vanilla for the high poly parts, since everything's wrong.

I tried a fix where you merge the export of the scary CK export with the desired nif, but even when I loaded up CK, it still showed the wrong face.

One thing I did notice, in the process of merging the nifs, was that the program seemed to think I'm using all the default face parts, even though I'm not (or at least I assume that's what the "01"s mean):
image.png.cc54bc706ee38efc9ccb9ce7a9153a52.png

Any ideas? I'm flummoxed. :D

Edited by Billkwando
Reduced black lines

Share this post


Link to post
Share on other sites

is there anyone know how to fix this some mistmatch color on face and body it seen in the image thank you

this one when not using high poly 

this one when not using high poly

this one when using high poly

this one when using high poly

Share this post


Link to post
Share on other sites
Author
Author of the topic Posted

@David Richard  It looks like you're using a custom head morph/sculpt in your preset that isn't supported by my high poly head mod.

@JUKIT  My load order detection code doesn't support ESL flags.  Also, never run the script on masters.  The intent is to run it on a patch created by the user (copy NPC records as Overrides into a new .esp).

@Billkwando  Using the CK method won't work on custom NPCs that use a sculpted head mesh.  The CK will only generate FaceGen based on head morphs.  You'll have to manually sculpt it using Outfit Studio, Blender, or 3DS Max.

@Neisa  It's literally in the description of this mod.

Quote

If the head turns dark, change the player weight to force the skin shader to update.

 

Share this post


Link to post
Share on other sites

Hello, I have an error in sseedit since the anniversary version was released: [00:00] Error during Applying script "Skyrim - KL Swap Headparts": Load order FileID [59] can not be mapped to file FileID for file " High Poly NPCs.esp "

I redid the order with LOOT, but nothing changes!

Share this post


Link to post
Share on other sites
15 hours ago, KouLeifoh said:

@David Richard  It looks like you're using a custom head morph/sculpt in your preset that isn't supported by my high poly head mod.

@JUKIT  My load order detection code doesn't support ESL flags.  Also, never run the script on masters.  The intent is to run it on a patch created by the user (copy NPC records as Overrides into a new .esp).

@Billkwando  Using the CK method won't work on custom NPCs that use a sculpted head mesh.  The CK will only generate FaceGen based on head morphs.  You'll have to manually sculpt it using Outfit Studio, Blender, or 3DS Max.

@Neisa  It's literally in the description of this mod.

 

Do you mean the shape of the actual noggin *behind* the face? I didn't think I had a sculpted head. I remember being afraid of those settings. Maybe I used it to trim some of the neck area and forgot. How do I get the high poly head into OS to get started trying?

Edited by Billkwando

Share this post


Link to post
Share on other sites
On 11/12/2021 at 7:30 AM, KouLeifoh said:

@Billkwando  Using the CK method won't work on custom NPCs that use a sculpted head mesh.  The CK will only generate FaceGen based on head morphs.  You'll have to manually sculpt it using Outfit Studio, Blender, or 3DS Max.

OK, so I followed a tutorial and successfully merged the heads by opening my desired head in Outfit Studio, exporting as OBJ, unload project, then importing the vanilla (deleting everything but the head) and HP head over top of each other, right clicking on vanilla on the right bar, choosing Set as Reference, and then going to slider, Create New Slider, OK, then clicking the pencil on the slider, going up to to the slider tab, doing import slider data and choosing the OBJ file. That morphs the head perfectly (she hasn't been smoothed yet, I know).

Spoiler

 

image.thumb.png.812869b4e171da29b75fd019c631fcdc.png

20211113_190816_MixedReality.thumb.jpg.b292b2faf447e751d43da6c61ab74a6e.jpg

The problem is, when I load her up in game, she's glitchy:

 

 

image.thumb.png.5ae4de1c7b391a46a0b65b158c3fc874.png

20211113_190830_MixedReality.thumb.jpg.a991c217a0df201821132ad167a632a5.jpg

20211113_190833_MixedReality.thumb.jpg.f7b77eb4d713107eb46c2a06ae0a274f.jpg

 

Those graphical glitches appear and disappear, randomly, depending on the angle I'm viewing her from. If I go back to the old head, it goes away.

As an aside, I also don't know how to add the other high poly parts in OS.

Any advice would be greatly appreciated :D

Here's the head in case it helps:
(For anyone trying to follow my steps above) I also forgot to mention that after you get the slider data imported, switch the slider back to the fat face, do Conform All under Slider (default settings), and then Set Base Shape. Then you can delete the vanilla head and do your smoothing.

00001835 - Copy (2).NIF

Share this post


Link to post
Share on other sites

I got the "brown beams" issue above, if I try converting the HP head, and the original head to LE, merging them with Nifmerge, and converting them back to SE.

I also tried importing the head in racemenu on SE to fix eyebrows and add HP parts, but since the paths are different, since it's an NPC and not a player character, I get the dark face bug, even though I've meticulously checked and corrected all the paths in Nifskope

Spoiler

Vanilla (sculpted?) head:

image.thumb.png.5615c3e57f47367a1def1e6334bc65d8.png

High Poly Head:

image.thumb.png.a3ea9d105ee0a17e56982fb044479ddf.png

The eye color looks right, but the rest appears to be the default potato face:

image.thumb.png.eaf29852b93c1af96008e4ff2f72a9b2.pngspacer.png

Edit: So I tried following Kalilies's guide, "How to edit NPCs without Nifmerge" and renamed all the tree items in Nifskope, as described, and I still got the brown beams coming out of her face, depending on where I'm standing, so it DID NOT work, sadly. Other than that, she looks great:

image.thumb.png.6dbabc9cd7ab3052001e75d3cdf2c631.png

I just tried it in SE too, so it's not a VR-only thing....just wanted to make sure:

image.thumb.png.9f5abf9e5572685eb6b847a618da5437.png

I'm trying everything I can to make it work on my own, but it's always dark face, or beam face.

I made a video of the "beam face" glitch above. Sorry I didn't think of it before:

Hope this helps

Share this post


Link to post
Share on other sites
Author
Author of the topic Posted

@HiroHaro The ESL flag is not supported.

@dbrown39 @David Richard It's up to Expired to update RaceMenu (specifically its skee.dll plugin).  While the source code for it is available on github, I don't know if it's updated nor do I want to touch it.

@Billkwando  When modifying an NPC's appearance, both the FaceGen data (.nif) and the NPC head part records (.esp) must match.  Otherwise, there will be the infamous black face issue (invalid facetint) or mesh distortion (invalid morphs).  It looks like you changed the FaceGen but didn't update the NPC records.

Share this post


Link to post
Share on other sites
8 hours ago, KouLeifoh said:

@HiroHaro The ESL flag is not supported.

@dbrown39 @David Richard It's up to Expired to update RaceMenu (specifically its skee.dll plugin).  While the source code for it is available on github, I don't know if it's updated nor do I want to touch it.

@Billkwando  When modifying an NPC's appearance, both the FaceGen data (.nif) and the NPC head part records (.esp) must match.  Otherwise, there will be the infamous black face issue (invalid facetint) or mesh distortion (invalid morphs).  It looks like you changed the FaceGen but didn't update the NPC records.

Thanks for the update! Very appreciated!!! So as I understand, High Poly Head does not need any update and will be compatible with AE once the author of RaceMenu updates his mod for AE?

Share this post


Link to post
Share on other sites

 

16 hours ago, KouLeifoh said:

@HiroHaro The ESL flag is not supported.

@dbrown39 @David Richard It's up to Expired to update RaceMenu (specifically its skee.dll plugin).  While the source code for it is available on github, I don't know if it's updated nor do I want to touch it.

@Billkwando  When modifying an NPC's appearance, both the FaceGen data (.nif) and the NPC head part records (.esp) must match.  Otherwise, there will be the infamous black face issue (invalid facetint) or mesh distortion (invalid morphs).  It looks like you changed the FaceGen but didn't update the NPC records.

I thought that was what I did in Nifskope, when I renamed everything to match the old head. Kaililis' instructions said the order of the tree doesn't matter, as long as they're renamed to match the CK head (the esm), which was what I thought I did.

image.thumb.png.778595f30f71acdb8dbcc729fa4f299c.png

 

The CK process was already done before, back when it was created as a low-poly head. Also, I'm guessing you've seen the beam face issue before? :)

Can you see anything wrong here? The old head is on the left.HPH on the right.

I'm attaching both heads in case you'd like to take a look.

I did try changing the Translation numbers to match the low poly head. That just resulted in her face vanishing when I got close (which was new) and beam face from further away.

Here's the comparison from the potato head export from Creation Kit, and my high poly head:

image.thumb.png.3b2446c9b57bd8a5eaec66c82fc92f2a.png

image.thumb.png.93dfae98018c8deb4861ae6d547fc70d.png

 

As far as I can tell, all the items match correctly.

 

I also made sure that the facetint RGB numbers in CK match my Racemenu export, and replaced my Facetint file with the one from the CK export.

As far as I can tell, I've followed all the directions and done everything correctly. Please help. There's nothing else I can think of to do and I've been working on trying to fix it myself for days.:)

Perhaps you could take a look to ensure there are no unforeseen technical issues? I don't want to give up.

00001835.NIF 00001835_messed up HPH.NIF

Edited by Billkwando

Share this post


Link to post
Share on other sites
Author
Author of the topic Posted

@David Richard  Correct.  The same applies to all mods that rely on RaceMenu.

@Billkwando  It seems you're adamant on doing everything except the one thing I suggested:  update the NPC records.  As you have stated, that was created for the low poly head.  It's telling the game that you're using the low poly head/brow meshes and, more importantly, the low poly head/brow morphs.  The "beam" you keep seeing is the game trying to use the low poly head/brow morphs with my high poly head/brow meshes.  They're not compatible.

Share this post


Link to post
Share on other sites
17 hours ago, KouLeifoh said:

@David Richard  Correct.  The same applies to all mods that rely on RaceMenu.

@Billkwando  It seems you're adamant on doing everything except the one thing I suggested:  update the NPC records.  As you have stated, that was created for the low poly head.  It's telling the game that you're using the low poly head/brow meshes and, more importantly, the low poly head/brow morphs.  The "beam" you keep seeing is the game trying to use the low poly head/brow morphs with my high poly head/brow meshes.  They're not compatible.

How do I update the NPC records? I went into CK and changed the facetint numbers, because they didn't match the numbers in Racemenu exactly.. The weight's right. I want do to what you're saying, I just don't understand what I need to change.

 

Edit: Since the guide I was following was about fixing faces and not high poly heads, I didn't realize I needed to swap all the TRIs and NIFs and ChargGens with the ones from your folder, I thought it was the brows in her Brows folders and face in FaceGeom and that was it. Sorry for the misunderstanding,

So the "beams" have gone away, and the only problem left is that her face disappears when I get close to her. I don't think it was doing that at the start of the "beam" problem, and I don't know how to fix it. Thoughts?

Thanks! I really appreciate you being patient. :)

EDIT 2: I got it!!! So I went back to my Racemenu exported head and redid the whole Nifskope process, and that fixed the missing skin. Thanks for sticking with me, and for all of your work on making big, beautiful, bulbous heads, of the detailed and functional variety!!! :P :P :P :P :P ;)

She looks great!!! :D

image.thumb.png.d4019c76cca03a45b292119ae22eb703.png

 

image.thumb.png.91cf45ec8968e8390f48e170579f0286.png

 

Now I can post an update of her over the weekend, with her fancy new noggin! I'll be sure to credit you too!

Edited by Billkwando

Share this post


Link to post
Share on other sites

With the AE update to SSE the high poly mod does not seem to work - The face part slider no longer shows in the head tab of racemenu. Not sure if its a issue i caused or if its the game

Share this post


Link to post
Share on other sites
5 hours ago, FuzdXeno said:

With the AE update to SSE the high poly mod does not seem to work - The face part slider no longer shows in the head tab of racemenu. Not sure if its a issue i caused or if its the game

Many mods of course will have problems with the new update. Make sure your basics like skse are up to date and working with the new update too. I hope you are using something like Mod Organizer since the update may change files if they were manually installed. I personally am not going to update skyrim since I don't want to deal with any issues that may crop up :p

Share this post


Link to post
Share on other sites
On 11/17/2021 at 9:38 AM, KouLeifoh said:

@HiroHaro The ESL flag is not supported.

Hello, thanks for the answer, but I have always done with the esl flag (on the file i create) and it has always worked! Are you creating the file in normal esp or esm?

But I notice the creation kit content (pack from anniversary edition) is detected as DLC (and don't select these files in the order) in LOOT, I wonder if this is not the cause of the problem, I will wait to see if there is a LOOT update coming soon. 

 

Edited by HiroHaro

Share this post


Link to post
Share on other sites
17 hours ago, Dr. Cheese said:

Many mods of course will have problems with the new update. Make sure your basics like skse are up to date and working with the new update too. I hope you are using something like Mod Organizer since the update may change files if they were manually installed. I personally am not going to update skyrim since I don't want to deal with any issues that may crop up 😛

I use mo2 skse is on the latest version and so is racemenu - i would revert back to the old game but eventually everything if not most will move to the new updated version so I'm saving myself a headache

Share this post


Link to post
Share on other sites

Is it too late to add EFA support if I excluded it in the original FOMOD install? I want to add it into my follower but I don't want to break her face again. The HPH parts are obviously built into her character and don't require HPH to be installed. I did reinstall it to check the box for EFA.

I've also heard reports that when reinstalling HPH and choosing the EFA option, the option to choose a new mouth doesn't appear, which was my experience.

Lastly, does EFA have to stay activated and in my load order to work with my follower, or is it something I can build into her, like HPH, so when other folks download her it will just work? If so, will I need to update the NPC records (now that I know how, lol) in CK again?

Edited by Billkwando

Share this post


Link to post
Share on other sites

When I meet certain vampire, the game will no response.I can only temporarily disable mod😢

(I hope google can translate correctly)

Edited by ShanYv

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.