Jump to content
  • Create an account

    Want more? Register now and get full access to our community!

ezzelo

[Help] Get SAM Morph to work with custom race

Recommended Posts

Hi! First of all thank you everyone for the amazing mod and addons, I'm still a noob in modding so I'd like to ask for a little help if possible!

 

I think got my custom race follower to work with SAM (I use SAM Light) by following the guide from here. When I use the SAM Morph on other vanilla character it works, but on my custom race follower it doesn't!

In game, my custom follower's body doesn't look like it uses SAM's body because it looks thin and a little weird. I changed the follower's weight to 100 in CK but it stays the same.

(NSFW Picture!!)

https://imgur.com/Oh1YHTh

https://imgur.com/qt1ohZF

(I also use SavrenX's Schlong of SAM)

 

My question is, how do I get SAM Morph to work with custom race? I have no more hair to pull out!

Or did I miss a step to make the custom follower's body compatible with SAM's? I mean, I followed the guide and it seems to work since the schlong appeared, but the body still doesn't look like SAM's buffed one, but rather thin and skeleton-ish like in the picture. Maybe it's because he has no Samson as default? But then again, I can't use SAM Morph on him to make any change! It works on vanilla characters and show the racemenu-like menu for me to morph, but when I use the command with the custom follower nothing happens. Nothing shows up.

I really really really appreciate any help I can get! Thank you thank you thank you in advance!!!

 

Below is my plugin list just in case it may help! (the follower esp is damienfollower.esp)

loadorder.txt

Share this post


Link to post
Share on other sites

SAM Morphs has a check for playable races to prevent players from accidentally targeting monsters/objects.  The quickest fix for a custom race is to set the race to Playable in its .esp file.  The alternative is to remove the check from SAM Morphs entirely.

This screenshot is an example of where the Playable flag is found on the default Nord race in xEdit.

rex0.thumb.jpg.f3f3a20bacc0c17a87d739898f005a15.jpg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...