Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Create an account

    Want more? Register now and get full access to our community!

Sign in to follow this  
Grays

XSoldier's John Bradford bugs

Recommended Posts

Hey guys!
I just bought XCOM2, which I've had my eye on for a while, because it was on sale on Steam!
It's been a little while, but thanks to the solutions you guys left, I was able to easily add the XSoldier mod. Thank you!!!

I'm still in the beginning stages, but the body shape, etc. is working fine.
I just have a problem with John Bradford's status.
Please see the attached picture. (I am playing with the Japanese version.)

He is not in the hero class "commando" as described in the mod, but has been changed to "ranger".
The rank icon is "img:". The first rank "Central Officer" is shown, but the table in the mod description should be "Squaddie".
The name of the skill tree is not shown.

I saw a few images uploaded in the comments of the mod and they were "Command" Class with no problem, so I don't know why.

I honestly fell in love with him at first sight and would like to solve this problem somehow.
I just started and have not installed any mods except XSoldier.
Can anyone help me with this?

268500_20220502053142_1.png

Share this post


Link to post
Share on other sites
Author

It has been a long time since I last played XCOM 2.. but if I remember correctly, XSoldier makes it possible to have Bradford's face on regular soldiers. It's possible this is just a regular soldier with his face. The real one i think is unlocked at some point in the game from some mission... i don't remember too well

Share this post


Link to post
Share on other sites
Author of the topic Posted (edited)

Thanks for the reply!

Unfortunately, I have proceeded to the DLC mission where he appears and cleared it, but nothing has changed.
I tried firing him before the mission started but he never respawned. A civilian soldier was assigned to animate in his place.
Also, I don't think this character is a soldier with a face assigned in the customization, but a john that spawns at the start of the campaign, as mentioned in the mod's description.
I even reinserted him into the vanilla folder, but that didn't help either.

I honestly wasn't going to make a topic for XCOM2 now, but I'm just curious from my experience of solving mod problems in Skyrim for several years. Haha.
Anyway, thanks for the tip.

I won't give up on solving this problem for a while. John loves.
I would be really happy if anyone else can help me.

 

PS

Hey guys! We did it! Experience didn't lie!!!!
It was very simple.

I am a newbie so I did a thorough investigation of how XCOM2 is made.
Then I found out which file the information that displays the icons and other information is composed of, and found out that it is "XComGame.int" which is in the "Localization" file.
Yes, we already have the answer.
Copy and paste "XComGame.int" and then change the extension to the language version you are using (in my case JPN).

That's all.

I solved it with a tip from Skyrim where you can only use mods in the English version!!! I'm so happy. It's refreshing.
If anyone else is using a language that isn't enclosed and has the same problem, give it a try!

Thanks everyone!!!

268500_20220503031922_1.png

Edited by Grays

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.