Jump to content
  • Create an account

    Want more? Register now and get full access to our community!

Sign in to follow this  
Kirax

Any ideas why this penis mesh is acting like this?

Recommended Posts

I mean it looks fine in outfit studio

1.jpg.fc40729ed919e1c9e3f0954280bf7e98.jpg

And it's morph file is in the .tri. There are no gaps anywhere

but in game I get this

2.jpg.7c88af72e4800db024998e32edd9b7c9.jpg

Any idea why?

Edited by Kirax

Share this post


Link to post
Share on other sites
1 hour ago, Kirax said:

I mean it looks fine in outfit studio

And it's morph file is in the .tri. There are no gaps anywhere

Any idea why?

Have you attached non-SAM genital mesh to SAM base body?

Then, the likeliest cause is a weight paint mismatch in the crotch area between the genital mesh and the base male body.

Copy the latter's weight paint around the crotch with the attached skin (NB: not the genital part itself!) of the former mesh, or only use SAM genital mesh for sam base body (that shares the totally matching weight paint).

 

Share this post


Link to post
Share on other sites
16 minutes ago, y_sengaku said:

Have you attached non-SAM genital mesh to SAM base body?

Then, the likeliest cause is a weight paint mismatch in the crotch area between the genital mesh and the base male body.

Copy the latter's weight paint around the crotch with the attached skin (NB: not the genital part itself!) of the former mesh, or only use SAM genital mesh for sam base body (that shares the totally matching weight paint).

  

This is an edited version of the SAM genital mesh.

The closest I can get the mesh to the original body is to erase all weights, but only paint it all blue at the pelvis bone.

What you said (copying the base male body's weight around the crotch area) does not work. The gap is huge. It's almost as if this mesh will only completely connect to the male body if I don't weigh it at all.

ScreenShot253.thumb.jpg.a09afadd889ca575c1e569cec723b846.jpg

Why can't everything just work? This is giving me a fucking headache

Share this post


Link to post
Share on other sites
2 minutes ago, Kirax said:

This is an edited version of the SAM genital mesh.

The closest I can get the mesh to the original body is to erase all weights, but only paint it all blue at the pelvis bone.

What you said (copying the base male body's weight around the crotch area) does not work. The gap is huge. It's almost as if this mesh will only completely connect to the male body if I don't weigh it at all.

Why can't everything just work? This is giving me a fucking headache

Thank you for close up SS.

Then, to double-check whether the reference skeleton of base body/ genital mesh is really male skeleton.nif or not. 

The mismatch between reference skeletons of both meshes  (Outfitstudio uses female one by default, and to adjust the mesh by OS often change the reference skeleton) also can such kind of gaps.

Share this post


Link to post
Share on other sites
2 minutes ago, y_sengaku said:

Thank you for close up SS.

Then, to double-check whether the reference skeleton of base body/ genital mesh is really male skeleton.nif or not. 

The mismatch between reference skeletons of both meshes  (Outfitstudio uses female one by default, and to adjust the mesh by OS often change the reference skeleton) also can such kind of gaps.

Christ that was it. Solved this bullshit.

I swear whoever set the default skeleton to female is a fucking retard like what the actual fuck

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×