Jump to content
  • Create an account

    Want more? Register now and get full access to our community!

air

[Guide] Refitting for SAM - Shape Atlas for Men

Recommended Posts

5 hours ago, air said:

selecting the bones I mentioned and then copying the weights normally shouldn't have an affect on the rest of the weighting... if you're sure this is the way you're doing it, then it might be that the original mesh has not actually been weighted in those masked areas. If that's the case then it might be fine as is, otherwise you may have to dabble with painting the weights on manually.

Thanks for the quick response, but unfortunately he did not give me specifics :с

I guess I should delay the conversion of clothes with HDT until I can understand how this HDT works with clothes.

Share this post


Link to post
Share on other sites

Heh, I have a question again, although I thought I figured out the usual clothes.

In general, after converting in the game for some reason the body is incorrectly displayed, saved with the clothes as a reference. Since I am converting from a female model (and body) to a male model, can this be the skeleton's fault? XPMS 32x was originally chosen, but it seems that something is still going wrong. The female body was also removed before morphing, unless SAM should replace its skeleton with its own, and remain the same in the game? With gloves and boots the same problem.

 

ScreenShot2108.png

ScreenShot2111.png

Share this post


Link to post
Share on other sites
On 12/4/2019 at 1:05 AM, Seagay said:

Heh, I have a question again, although I thought I figured out the usual clothes.

In general, after converting in the game for some reason the body is incorrectly displayed, saved with the clothes as a reference. Since I am converting from a female model (and body) to a male model, can this be the skeleton's fault? XPMS 32x was originally chosen, but it seems that something is still going wrong. The female body was also removed before morphing, unless SAM should replace its skeleton with its own, and remain the same in the game? With gloves and boots the same problem.

I can't really see what's going on there at all... but I doubt it's a skeleton issue

Share this post


Link to post
Share on other sites

Wow! I managed to do a refit! I'm almost ashamed that it is not so good like the ones I've seen in the NSFW Screenshot showoff thread, but it is a start...

Thank you for your guide! It's great and really helped!

And I have a question: if I wanted to refit a female only armor to my male character, I would have to modify the esp too? Right? What do I have to do exactly and how? 

I wanted something like this https://skyrimscandal.blogspot.com/2017/01/full-metal-bikini-mark-ii-unp-diana.html (I won't put a screenshot of a half naked woman here, don't worry guys) and I know it's a dificult one because of the codpiece (much patience needed) and the high heels (I'm not really into high heels... plain boots are best!)

05.jpg.80b6e6575f88237ea292bcb42d476340.jpg

  • Like 1

Share this post


Link to post
Share on other sites
9 hours ago, ft. GB said:

Wow! I managed to do a refit! I'm almost ashamed that it is not so good like the ones I've seen in the NSFW Screenshot showoff thread, but it is a start...

Thank you for your guide! It's great and really helped!

And I have a question: if I wanted to refit a female only armor to my male character, I would have to modify the esp too? Right? What do I have to do exactly and how? 

I wanted something like this https://skyrimscandal.blogspot.com/2017/01/full-metal-bikini-mark-ii-unp-diana.html (I won't put a screenshot of a half naked woman here, don't worry guys) and I know it's a dificult one because of the codpiece (much patience needed) and the high heels (I'm not really into high heels... plain boots are best!)

 

Great! I'm glad it helped.

To enable the armor for males you'll have to add the directories for the male meshes in the esp. It's probably easier in TES5Edit/SSEdit. You have to expand the armor addon section and add in the path next to male world model (and first person model too, if you want)

Share this post


Link to post
Share on other sites

Hi
I'm trying to refit SAM Adult Accessories for SAM Light on Special Edition. 

 

When I import the .nif files into outfit studio the textures are missing (it says no image).

Building the morphs in bodyslide causes the textures to be missing in game (purple textures in game)

The SAM Morphs and sliders all work in game except the rings are all purple, am i missing a step?

Any help is appreciated :)

image.thumb.png.83a40d0f7313bbfbaaff09c1cc1d6324.png

Share this post


Link to post
Share on other sites
2 hours ago, polary said:

Hi
I'm trying to refit SAM Adult Accessories for SAM Light on Special Edition. 

 

When I import the .nif files into outfit studio the textures are missing (it says no image).

Building the morphs in bodyslide causes the textures to be missing in game (purple textures in game)

The SAM Morphs and sliders all work in game except the rings are all purple, am i missing a step?

Any help is appreciated :)

 

Most likely the texture swapping is failing due to the nitrishapes on  your refit not being in the same position as the original (see my post in the middle of page 3)

also i'm not sure whether or not you're including the body and genitals in your final refit, but if you are it's unnecessary and you should delete them

Share this post


Link to post
Share on other sites
16 minutes ago, air said:

Most likely the texture swapping is failing due to the nitrishapes on  your refit not being in the same position as the original (see my post in the middle of page 3)

also i'm not sure whether or not you're including the body and genitals in your final refit, but if you are it's unnecessary and you should delete them

Thanks!
This solved the issue :)

  • Upvote 1

Share this post


Link to post
Share on other sites

:) Converting all revealing armors in bodyslide to hdt is taking me a while but things are working great :D, So ty air for the guide and the bodyslide conversion references :D

  • Upvote 1

Share this post


Link to post
Share on other sites

Excuse me,

I tried following the guide, but I'm guessing since I'm using SAM Lite, at the 4A, the drop-down list of Outfit/Body on mine has nothing, other than fail refits I've done before (first time it was blank, after I chose skeleton.nif from BodySlide's settings).

So then I skip 4A and manually open OutfitStudio, I import [to NIF...] the malebody_1.nif in character assets folder and then the outfit I'm refitting. Then I went to Slider, importing the .TRI with malebody.tri file from character assets folder.

I followed the guide correctly, and then Save Project as, I chose a Display Name: Male Trousers, then clicked "To Project". Then I typed in the original file name for the outfit I used for refitting, and the Output Data Path starting with \meshes\Ashara\Prince of The Woods\. I checked the "Copy reference shape into output" box. I saved it and then quit the OutfitStudio.

I closed BodySlide and re-open it, checked that it still has the same skeleton.nif on the settings. Then the new "Male Trousers" is on the Outfit/Body drop down list, so I chose it. But there is no "Weight 1 to 0" slider appearing. Do notice that when I'm importing malebody_1.nif, PrinceTrousers_1.nif, and importing malebody.tri, there are no "Weight 1 to 0" slider. I only have "Samson" "Samuel" "PenisSize" "PenisTaper" "ForeskinHide" "Genital UV" "ScrotumSize". (I deleted the genital parts before began refitting)

But I try to click "Build" anyway, and succesfully created the new .nif and .tri files.

I checked and the overwritten .nif outift and the new .tri file are there in the same folder. With correct name too.

But when I try to use it in-game, it didn't fit with the character size...

Share this post


Link to post
Share on other sites
1 hour ago, Grazzald said:

Excuse me,

I tried following the guide, but I'm guessing since I'm using SAM Lite, at the 4A, the drop-down list of Outfit/Body on mine has nothing, other than fail refits I've done before (first time it was blank, after I chose skeleton.nif from BodySlide's settings).

So then I skip 4A and manually open OutfitStudio, I import [to NIF...] the malebody_1.nif in character assets folder and then the outfit I'm refitting. Then I went to Slider, importing the .TRI with malebody.tri file from character assets folder.

I followed the guide correctly, and then Save Project as, I chose a Display Name: Male Trousers, then clicked "To Project". Then I typed in the original file name for the outfit I used for refitting, and the Output Data Path starting with \meshes\Ashara\Prince of The Woods\. I checked the "Copy reference shape into output" box. I saved it and then quit the OutfitStudio.

I closed BodySlide and re-open it, checked that it still has the same skeleton.nif on the settings. Then the new "Male Trousers" is on the Outfit/Body drop down list, so I chose it. But there is no "Weight 1 to 0" slider appearing. Do notice that when I'm importing malebody_1.nif, PrinceTrousers_1.nif, and importing malebody.tri, there are no "Weight 1 to 0" slider. I only have "Samson" "Samuel" "PenisSize" "PenisTaper" "ForeskinHide" "Genital UV" "ScrotumSize". (I deleted the genital parts before began refitting)

But I try to click "Build" anyway, and succesfully created the new .nif and .tri files.

I checked and the overwritten .nif outift and the new .tri file are there in the same folder. With correct name too.

But when I try to use it in-game, it didn't fit with the character size...

You skip a lot of the steps, so of course it won't work ?

If the slider sets are not showing in the drop-down list, it means you have not installed them to your bodyslide folder properly. Put them in the same place as the preexisting folder.

The .tri file which I used to create these slider sets is not the same as malebody.tri. This guide is not meant to be used with that .tri file and it won't work with it at all. This is leading to all your other issues which you described.

For the future, if you follow a tutorial and get stuck, it's best to figure out the issue right there or ask for help about that right away, instead of ignore the issue and continue hoping that everything will be ok. I put those steps there because they're important! ?

Share this post


Link to post
Share on other sites
6 hours ago, air said:

You skip a lot of the steps, so of course it won't work ?

If the slider sets are not showing in the drop-down list, it means you have not installed them to your bodyslide folder properly. Put them in the same place as the preexisting folder.

The .tri file which I used to create these slider sets is not the same as malebody.tri. This guide is not meant to be used with that .tri file and it won't work with it at all. This is leading to all your other issues which you described.

For the future, if you follow a tutorial and get stuck, it's best to figure out the issue right there or ask for help about that right away, instead of ignore the issue and continue hoping that everything will be ok. I put those steps there because they're important! ?

Aha okay, first thing first I'm sorry that apparently I ignored important parts.

1. I thought the slider is not showing because I'm using SAM Lite, since I assume Lite means less features.

2. So then which .tri file I should be using..? Unless I missed it, I can't find it in the guide.

3. I did not ignore them since I didn't get stuck there. When there is no "Weight 1 to 0" slider, I assume I won't be able to continue the steps, but I can, so I try to follow it until I cannot progress along the line. It doesn't feel right to ask on every little bit, since I assume I would annoy the heck out of other people...

But thank you for answering, now I will try to get the slider sets first in the drop down menu of BodySlide, and trying again ^^

Share this post


Link to post
Share on other sites

Btw, where can I find the .nif used for default underwear..? I want to use the Underwear (it looks like a skimpy, light-brown colored briefs. Not the vanilla one) as reference while refitting, since in-game the underwear is protruding on some parts.

I tried deleting vertices of the SAMBody around where it protrudes, but apparently the underwear is not related to that...

EDIT: Also I don't quite understand the use for deleting vertices in the guide. Since when your character moves, the limbs are still protruding. So you still need to do some edits with the increase/decrease/smooth mesh tools in order to cover those parts.

EDIT2: I tried quick searching but there seems none. Is there a guide on how to refit SE headgear..?

Edited by Grazzald

Share this post


Link to post
Share on other sites
Quote

1. I thought the slider is not showing because I'm using SAM Lite, since I assume Lite means less features.

No, it's not showing because the files are installed to the wrong location. Your SAM installation does not matter here; the files I provided to download include sets for all versions of SAM available to LE and SE.

Quote

2. So then which .tri file I should be using..? Unless I missed it, I can't find it in the guide.

There's no need to use a .tri file, which is why it's not mentioned in the guide. The slider sets I've provided for download have all the slider data in them already.

Quote

3. I did not ignore them since I didn't get stuck there. When there is no "Weight 1 to 0" slider, I assume I won't be able to continue the steps, but I can, so I try to follow it until I cannot progress along the line. It doesn't feel right to ask on every little bit, since I assume I would annoy the heck out of other people...

There is no weight 1 to 0 slider because you used malebody.tri. The weight 1 to 0 slider was added by me and you would only see it using the slider sets I put for download. This slider is only useful for refitting and that's why I added it. This is why it's important to figure out that first step of installing my files correctly, otherwise if you follow the rest of the guide it won't work.

Quote

Btw, where can I find the .nif used for default underwear..? I want to use the Underwear (it looks like a skimpy, light-brown colored briefs. Not the vanilla one) as reference while refitting, since in-game the underwear is protruding on some parts.

I'm not sure which underwear this is, because the default underwear for SAM is black as far as I am aware..o_O

If you're using SAM Light and you downloaded the no-nudity option then you would find the underwear in the malebody.nif

Quote

EDIT: Also I don't quite understand the use for deleting vertices in the guide. Since when your character moves, the limbs are still protruding. So you still need to do some edits with the increase/decrease/smooth mesh tools in order to cover those parts

if you delete something, there's no way it can still be protruding ?

Quote

EDIT2: I tried quick searching but there seems none. Is there a guide on how to refit SE headgear..?

usually headgear does not need refitting since the head shape is not changed from vanilla by SAM. But if you want to refit it anyway then it's just a matter of putting it in outfit studio and changing it how you like.

Edited by air

Share this post


Link to post
Share on other sites
11 hours ago, air said:

 

if you delete something, there's no way it can still be protruding ?

usually headgear does not need refitting since the head shape is not changed from vanilla by SAM. But if you want to refit it anyway then it's just a matter of putting it in outfit studio and changing it how you like.

I did delete the SAMBody parts that is supposedly protruding in OutfitStudio, but in-game, it seems the original body mesh is still there (2 stacks of same SAMBody, one from the refit which I removed some of its body parts, and one from the naked body fully intact).

I think it might be because of the armor's slot. Since as far as I know, when equipping body armor, the underwear supposed to be gone, but in my case it's as if my character is not wearing body armor slot, thus the underwear is still there showing when sneaking/jumping.

I'm not sure how to change the armor slot (if it's indeed the problem), or if I even gave the correct file to check.. help me please >3<

And yeah I found out that the headgear mod I used is the one with the problem, not because it needs refit.

PrinceTrousers_1.nif

Share this post


Link to post
Share on other sites
1 hour ago, Grazzald said:

I did delete the SAMBody parts that is supposedly protruding in OutfitStudio, but in-game, it seems the original body mesh is still there (2 stacks of same SAMBody, one from the refit which I removed some of its body parts, and one from the naked body fully intact).

I think it might be because of the armor's slot. Since as far as I know, when equipping body armor, the underwear supposed to be gone, but in my case it's as if my character is not wearing body armor slot, thus the underwear is still there showing when sneaking/jumping.

I'm not sure how to change the armor slot (if it's indeed the problem), or if I even gave the correct file to check.. help me please >3<

And yeah I found out that the headgear mod I used is the one with the problem, not because it needs refit.

PrinceTrousers_1.nif

Unfortunately I don't have access to my PC right now to check the file, but yes if it's not using slot 32 then the body won't be hidden. The body parts will show as long as their slots are not in use, and using the slot will hide it.

To change the slot you need to change it in armor addon of the esp and you might also need to change it in BSDismemberProperty in the nif, if it's there. There's a lot of posts out there about how to change the slot, here's one I found in a quick search: https://forums.nexusmods.com/index.php?/topic/576983-tutorial-assign-meshes-to-new-body-parts/

 

Edited by air
  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, air said:

Unfortunately I don't have access to my PC right now to check the file, but yes if it's not using slot 32 then the body won't be hidden. The body parts will show as long as their slots are not in use, and using the slot will hide it.

To change the slot you need to change it in armor addon of the esp and you might also need to change it in BSDismemberProperty in the nif, if it's there. There's a lot of posts out there about how to change the slot, here's one I found in a quick search: https://forums.nexusmods.com/index.php?/topic/576983-tutorial-assign-meshes-to-new-body-parts/

 

Yey I did it! I changed the armor slot~ now I don't need to increase the bulge on some parts of the trouser or even messing with the underwear.

Thanks alot air, for responding to my (I assume) pretty stupid mistakes and questions~ ?

Share this post


Link to post
Share on other sites
2 hours ago, Grazzald said:

Yey I did it! I changed the armor slot~ now I don't need to increase the bulge on some parts of the trouser or even messing with the underwear.

Thanks alot air, for responding to my (I assume) pretty stupid mistakes and questions~ ?

Don't worry, I'm glad to answer any questions as long as I know the answer ?

Share this post


Link to post
Share on other sites

Hey!
I finished refitting this mod:

but how do I remove the physics ? I'm not using a physics body so the rings become misaligned.
Do i do this in bodyslide or nifskope?

any help is appreciated :D

Share this post


Link to post
Share on other sites
8 hours ago, polary said:

Hey!
I finished refitting this mod:

but how do I remove the physics ? I'm not using a physics body so the rings become misaligned.
Do i do this in bodyslide or nifskope?

any help is appreciated :D

Put the meshes in outfit studio, select all pieces, and go to the bones tab. Then delete the breast bones (left and right) and the belly bone. Then open the nif in nifskope and remove the nistringextradata at the top pointing to the hdt xml

it should work but make a backup just in case something goes wrong 

Share this post


Link to post
Share on other sites
On 1/27/2020 at 12:30 AM, air said:

Put the meshes in outfit studio, select all pieces, and go to the bones tab. Then delete the breast bones (left and right) and the belly bone. Then open the nif in nifskope and remove the nistringextradata at the top pointing to the hdt xml

it should work but make a backup just in case something goes wrong 

I tried deleting the breast bones - but it deletes the ring as well.

Is this supposed to happen? Or is it just not possible to remove HDT from these :(

Thanks for any help

Share this post


Link to post
Share on other sites
On 1/30/2020 at 7:42 AM, polary said:

I tried deleting the breast bones - but it deletes the ring as well.

Is this supposed to happen? Or is it just not possible to remove HDT from these :(

Thanks for any help

no, that shouldn't happen ?

Share this post


Link to post
Share on other sites

I tried making my own refit for an armor mod called "Leather Mashup Collection" ( https://www.nexusmods.com/skyrim/mods/79027 ). I spent what felt like 4 Hours doing this, but only for the one armor piece i was going to use on my character. Which was the "Light Shirt" variant.

In the editor the armor seemed like it worked out fine.

But when i got ingame it did not change anything, I even downloaded TES5Edit and it has weight sliding enabled already.

This is for Oldrim" Legendary Edition.

If you could look at it and tell me what I'm doing wrong that would be great.

I only edited _1.nif since _0.nif already existed and i assume i don't have to do anything for it, but im including it just incase.

 

BrownShirtLight_0.nif

BrownShirtLight_1.nif

Share this post


Link to post
Share on other sites

Okay so I actually figured out why it was not working.

The armor now seems to show ingame, but the cloth looks blocky and jagged where the Pecs are, i tried to smooth it out to make it look more round, and i tried to decrease the point too. but nothing seems to be working :/

This is the most modding I've ever done and i really dont know what to do.

This is what it looks like in the outfit studio, and it looks similar to this ingame, making angled shots look odd with the blocky chest.

Another issue I have is ingame some skins seems to clip outside the cloth as well, I assume just inflating the area is what works best.

but then i run into another issue when holding weapons and such, the cloth does not move with the arm at the time i post this comment.

Screenshot_1.png

Share this post


Link to post
Share on other sites
6 hours ago, Scakk said:

Okay so I actually figured out why it was not working.

The armor now seems to show ingame, but the cloth looks blocky and jagged where the Pecs are, i tried to smooth it out to make it look more round, and i tried to decrease the point too. but nothing seems to be working :/

This is the most modding I've ever done and i really dont know what to do.

This is what it looks like in the outfit studio, and it looks similar to this ingame, making angled shots look odd with the blocky chest.

Another issue I have is ingame some skins seems to clip outside the cloth as well, I assume just inflating the area is what works best.

but then i run into another issue when holding weapons and such, the cloth does not move with the arm at the time i post this comment.

Screenshot_1.png

The sharpness is inevitable with these kind of  low-poly meshes. The only way to minimize this is to avoid using the inflate tool as much as possible. Delete the vertices of the body which is being covered by the clothing, so that you wont need to inflate the clothing so much over the body. And maybe consider scaling the size of the clothing up too, to give a starting point with less clipping.

Second issue again, its inevitable. In outfit studio the body is fixed in 1 position and nothing is moving. but in game the character is moving around and they're in different positions all the time, even when idle. Because of that sometimes you wont see clipping in OS but will see it in game.. it just means you have to go back and compensate for that, either by inflating a bit more or deleting whatevers clipping through.

The third issue sounds like an issue with the weighting. Unfortunately that's quite advanced, its outside of the scope of my little guide here but I'm sure theres many guides on painting weights elsewhere if you would like to fix it.

Edited by air

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...